I don’t want to open a great can of bike shedding here, but just give feedback on something that continues to confuse me: I keep mixing up
List.append with one another.
I do think the current names make sense once you think about them, but they are still so similar I always have to check the type signatures of
append to find out which one I want. Renaming one of them to make their uses more distinct is something I would personally appreciate. Using
flatten instead of
concat is the first thing that comes to my mind, since that’s also the terminology I’m used to, but YMMV