Elm can't fetch the package list with a HTTPS error

I tried to start a new project with elm init, but it says it can’t reach the package list.

Is there any way I can tell elm to use the system certificate store?
(The firewall for work adds its certificates there)

I have verified that I can access that URL through the browser.

I need the list of published packages before I can start initializing projects,
so I tried to fetch:


But my HTTP library is giving me the following error message:

InternalException (HandshakeFailed (Error_Protocol (“certificate rejected: [InvalidSignature SignatureInvalid]”,True,CertificateUnknown)))

Are you somewhere with a slow internet connection? Or no internet? Does the link
I am trying to fetch work in your browser? Maybe the site is down? Does your
internet connection have a firewall that blocks certain domains? It is usually
something like that!

1 Like

How do you tell other tools to use the system certificate store?

For example, what do you need to do to make curl https://package.elm-lang.org/all-packages work?


In order to get curl https://package.elm-lang.org/all-packages to work, I have to pass --ssl-no-revoke (Disabling certificate revocation checks with Schannel)

Otherwise, it gives this:

C:\> curl https://package.elm-lang.org/all-packages
curl: (35) schannel: next InitializeSecurityContext failed: Unknown error (0x80092012) - The revocation function was unable to check revocation for the certificate.

I am on Windows.

Just looking at the error further, it appears to be a problem with the signature, not the actual root CA.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.