Is my install of elm-app broken?

Since yesterday my Elm app (created with create-elm-app) refuses to compile, with an unusually unhelpful message:

Failed to compile

./src/Main.elmError: Compiler process exited with error Compilation failed

This error occurred during the build time and cannot be dismissed.

It worked fine the last time I worked on it. (I had a cyclic dependency issue on one of my branches. Now, all of my branches won’t compile, with the same generic error message.

The same error occurs using either elm-app start or elm-app build. What happened?

It doesn’t seem to have anything to do with the code itself, but just in case: (also it’s a few commits behind my local repo)

PS: At the same time, Sublime’s “Elm format on save” plugin seemed to be broken in a dangerous way, completely emptying any Elm file I would try to save… I disabled the plugin and it fixed the problem. I would think there’s no relation with the main issue I mentioned here, but just in case, I thought I should mention it as well.

This link is broken. It throws a 404 error.

I’ve been using this plugin since May without any issues. Maybe it is the interaction with some other plugins that you have.

Oh sorry, the repo is private actually, I completely forgot about that!

Anyway, problem fixed now! I just ran yarn global upgrade create-elm-app, and all is well now. create-elm-app was apparently broken in my environment since it was also unable to create new projects.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.