Skinney/murmur3 on elm 0.18.0

I see the following stack trace after building my elm project:

Some new packages are needed. Here is the upgrade plan.

    Bogdanp/elm-combine 3.1.1
    NoRedInk/elm-decode-pipeline 3.0.1
    Skinney/murmur3 2.0.6
    coreytrampe/elm-vendor 2.0.3
    elm-community/lazy-list 1.0.0
    elm-community/random-extra 2.0.0
    elm-community/shrink 2.0.0
    elm-community/undo-redo 2.0.0
    elm-lang/core 5.1.1
    elm-lang/dom 1.1.1
    elm-lang/html 2.0.0
    elm-lang/http 1.0.0
    elm-lang/keyboard 1.0.1
    elm-lang/lazy 2.0.0
    elm-lang/mouse 1.0.1
    elm-lang/navigation 2.1.0
    elm-lang/virtual-dom 2.0.4
    evancz/elm-markdown 3.0.2
    evancz/url-parser 2.0.1
    ir4y/elm-dnd 2.0.0
    krisajenkins/remotedata 4.5.0
    rtfeldman/elm-css 14.0.0
    rtfeldman/elm-css-util 1.0.2
    rtfeldman/hex 1.0.0
    thebritican/elm-autocomplete 4.0.3

Do you approve of this plan? [Y/n] y
Starting downloads...

  ÔŚĆ coreytrampe/elm-vendor 2.0.3
  ÔŚĆ NoRedInk/elm-decode-pipeline 3.0.1
  ÔťŚ Skinney/murmur3 2.0.6
  ÔŚĆ Bogdanp/elm-combine 3.1.1
  ÔŚĆ elm-lang/html 2.0.0
  ÔŚĆ elm-lang/lazy 2.0.0
  ÔŚĆ elm-community/lazy-list 1.0.0
  ÔŚĆ elm-community/undo-redo 2.0.0
  ÔŚĆ elm-lang/virtual-dom 2.0.4
  ÔŚĆ rtfeldman/elm-css-util 1.0.2
  ÔŚĆ ir4y/elm-dnd 2.0.0
  ÔŚĆ elm-community/random-extra 2.0.0
  ÔŚĆ elm-lang/http 1.0.0
  ÔŚĆ evancz/elm-markdown 3.0.2
  ÔŚĆ elm-lang/mouse 1.0.1
  ÔŚĆ elm-lang/core 5.1.1
  ÔŚĆ elm-community/shrink 2.0.0
  ÔŚĆ krisajenkins/remotedata 4.5.0
  ÔŚĆ rtfeldman/hex 1.0.0
  ÔŚĆ elm-lang/dom 1.1.1
  ÔŚĆ evancz/url-parser 2.0.1
  ÔŚĆ elm-lang/keyboard 1.0.1
  ÔŚĆ elm-lang/navigation 2.1.0
  ÔŚĆ thebritican/elm-autocomplete 4.0.3
  Error: The folÔŚĆlowing HTTP rtfeldman/elm-css 14.0.0
 request failed.

404: Not Found

I saw this post: Skinney/murmur3 not downloading but there the issue is solved only for elm 0.19.0. Any ideas how can I make it work for 0.18.0?

I do not recall exactly how the 0.18 download process works, but here’s what I would try.

If I remember correctly, the packages are all downloaded into folders in your project’s elm-stuff/ directory like this:


If I recall correctly, it downloads the package when it does not see a src/ directory on that path, so if you download the code yourself into that location, I think 0.18.0 will assume that it downloaded it in the past.

I’m not 100% certain that I am remembering all the details, but I think this is roughly what I would look into first!

Thanks for your suggestion, I already tried that. The problem is, that in the github repository the code is written in elm 0.19 so it’s not compatible with my version (there is no elm-package.json, only elm.json). Btw if I could find an older version of it I think it should work

Have you tried downloading the module file into your src folder? From a cursory look at the module it doesn’t seam to depend on any 0.19 specific code and I would not be surprised if it work just fine with 0.18

Alternatively, you could download the source code at this commit and use Evan’s instructions to install it into your 0.18 elm-stuff location.

Yep, cloning the source code at the commit you suggested into the elm-stuff folder indeed works. Thank you guys for your help, much appreciated!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.