I can't find docs for Elm 0.18 and packages related to Elm 0.18

I am new to Elm, but I’ll be using version 0.18 because I’m creating the backend in Phoenix and elm-phoenix-socket isn’t yet updated to be used with Elm 0.19.
As I’m new so I’ll be reading the docs often, but I can’t find docs for version 0.18 on the official site. I also can’t find the packages related to version 0.18, like elm-phoenix-socket package.


General instructions on searching for an Elm 0.18 package (link is also accessible if you search for something that isn’t available in the 0.19 package server).

And here are the fbonetti/elm-phoenix-socket docs.

1 Like

I quickly hacked a page (using the official packages site API and CSS) to search for 0.18 packages during the transition. By default it displays all “elm-lang” packages:


Hopefully this won’t put too much bandwidth pressure on the package.elm-lang.org website, else I will remove it.


This page is very helpful, thank you!

Many thanks for doing this; very very helpful at the moment to keep 0.18 working - I am sure there are many of us still transitioning to 0.19.

I ran into this problem 0.18 dependency recently:

    rtfeldman/elm-css": "14.0.0 <= v < 15.0.0"

This broke because it depends on Skinney/murmur3": "2.0.6 <= v < 3.0.0, but 2.0.7 was released for 0.19. This meant that the build tried to fetch 2.0.7, but as it did not have an elm-package.json, only an elm.json, the build failed.

The solution was to explicitly add murmur3:2.0.6 in my dependencies before elm-css:

    "Skinney/murmur3": "2.0.6 <= v < 2.0.7",
    "rtfeldman/elm-css": "14.0.0 <= v < 15.0.0",

If there is an easy way to figure out “package rot” like this from the package API and mark it in your UI, that might be a useful addition. Anyway, I mention it in case people are getting strange errors about missing elm-package.json and can make use of this work around.

1 Like

I don’t use any backend and I don’t want to download tons of json files from the official website, so I can’t add many features.

However, I just tested creating a new 0.18 program and installing rtfeldman/elm-css and I got no issues. It installed elm-css 15.0.0, but then I downgraded to rtfeldman/elm-css": "14.0.0 <= v < 15.0.0 in my elm-package.json and again got no issues. So I wonder how you got into this conflicting state.

If you load your elm-package.json to my update checker, it provides links to the documentation. I’m not currently parsing version numbers, but it works well for missing/renamed packages, and you can change versions on others from the doc site.

Ok, good to hear, so I guess 0.18 packages should continue to work without issue? Weird that I got this problem, I even deleted all caches and it still happened - strangely on one machine and not another…

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.