Complete blank with 0.19

Working on a new Windows machine, decided to make the switch to 0.19. Installed 0.19, called up an 0.18 project to see what errors would occur on compiling.


Typing ‘elm make’ at the command prompt just goes back to the command prompt. So does ‘elm reactor’. The command is being recognised, since typing the old ‘elm-reactor’ command generates an error.

The elm binary is in the environment path, and I’ve tried running as administrator. Still nothing.

Has anyone else run into this? Failing that, can I still get back to an 0.18 install to retrieve months of work?

OK, figured it – I have to clear everything out which was generated by 0.18, those folders which I used to ignore, just leave the basic Elm code in place, and I get a response.

Be sure to check out elm-upgrade if you haven’t already.

I did that first, couldn’t get it to install - it’s an alpha version, after all.

I think I’ve worked it out - I just have to delete the generated elm.js and app.js files every time before I do a recompile, which is a considerable drag.

My question still stands - is there an 0.18 installer around somewhere I can go back to for faster development?

You can install Elm locally per project via npm.

npm install --save-dev elm@0.18.0

The binaries then get installed into ./node_modules/.bin/.

1 Like

Excellent! Thanks for the prompt solution.

@sch made a nice gist about this:


Excellent info, once again, thanks.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.