What's the matter with Ellie?

module Main exposing (main)

import Html as HT

main = HT.text (String.fromFloat pi)

{-
Even the simplest code so as the above one 
is not working now on ellie-app.com.

Does somebody know, why Ellie says this?
  Exception Thrown in Output
  ReferenceError: Elm is not defined
-}

I have checked my earlier links in Ellie too - they work neither anymore.

3 Likes

It’s working as I write this comment. Maybe some temporary error with calling Elm runtime?

Try clearing all of your browser data for Ellie (cookies, localStorage, etc.). I ran into a similar problem recently and that fixed it.

That seems to be a browser specific problem and only with Firefox, both Ubuntu on PC as on Apple M1 Pro macOS Sonoma 14.5.
Clearing all history and cookies of Firefox did not solve the problem.

Fortunately Ellie seems to be Ok with other browsers, Safari and DuckDuckGo.

You need to turn off “Enhanced Tracking Protection” in Firefox.

3 Likes

Yes, that helped immediatelly! Now Ellie works again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.