Elm 0.19.1 looking for wrong modules

I’m getting a strange error:

-- MODULE NOT FOUND --------------------------------------------------- View.elm

You are trying to import a `Menucanvasmsg` module:

12| import Menucanvasmsg
I checked the "dependencies" and "source-directories" listed in your elm.json,
but I cannot find it! Maybe it is a typo for one of these names?


Hint: If it is not a typo, check the "dependencies" and "source-directories" of
your elm.json to make sure all the packages you need are listed there!

The file “menucanvasmsg.elm” is located in the root folder. It has a module “Menucanvasmsg”. None of the names above exist. I’ve tried deleting the “elm-stuff” folder.

Any clue what’s going on?

Try renaming the file to “Menucanvasmsg.elm” with capital “M” - Elm 0.19.1 is stricter with filenames than 0.19.0


I’ve already tried that. Doesn’t work unfortunately.

OK, the problem was that the new naming enforcement had me a bit confused. There was no problem with Elm.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.