Elm-UI different behaviour in Ellie and Reactor

I want to use Elm-UI to split the screen horizontally into two equal-height rows. I thought I could do this with a column containing two rows with each row having “height <| fillPortion 1”. The code works perfectly in Ellie [https://ellie-app.com/dWjmvfM6BRSa1], with the the two rows having the same height and the contents of the first row being clipped. When I run the same code in reactor the first row has been expanded so the contents are not clipped, and the first row is now taller than the second row.
Is my code correct and, if so, how do I get it to behave the same way using reaxctot as it does using Ellie?

You can use create-elm-app to bootstrap your app. I, and many others, use it for projects of any size as it addresses the limitations of out-of-box options:

I tested your code with create-elm-app and it works just like in Ellie. Let me know if you encounter any trouble setting up create-elm-app.

1 Like

Nice riddle. I tried to figure it out but I could not find the reason. It should behave the same

I had a similar issue (had to do with clipping a scrolling region in a column I think), it turned out that elm-ui had patch updates; ellie got the newer one with the issued fixed, while my project had been locked to the elm-ui version at the time of project creation.


Many thanks! I updated my dependencies using https://github.com/zwilias/elm-json and the reactor version now behaves as it should. I’m now using Elm-UI 1.1.8 whereas previously it was 1.1.0.

Thanks very much for your suggestion. As the solution suggested by https://discourse.elm-lang.org/u/wondible works I’ll carry on using reactor for the time being - but I’ll certainly investigate create-elm-app when I’ve more time available.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.