[FIXED] Fixing Elm-Make 0.19 in VS Code 1.27.2

Hi :slight_smile:
As the title says, I’m trying to have Elm 0.19 work in VS Code 1.27.2, under Ubuntu 18.04.

I managed to install the Elm relevant packages and the Format tool too. But whenever I save the file it tells me that Elm-Make is not installed.
Searching the web I’ve found discussions of people mentioning “problems with the $PATH” or something… but I couldn’t figure out what I was supposed to do :confused:

Can anyone help me?
Thx! :smiley:

As a good n00b I did a stupidly n00b mistake.
I tried writing some test elm code without a proper project.
The moment I made a new folder and run elm init all was solved :stuck_out_tongue:

Meh. All is well that ends. Period.

The VS Code Elm plugin doesn’t support 0.19 yet as far as I know.

Elm 0.19 has no elm-make executable. That’s why it’s not found. There used to be several command line tools but now there’s just one executable called elm. The plugin developers will need to update it.
I’d suggest having a look at the open issues in the GitHub repo for the plugin to see what their plans are.

Thx Brian :slight_smile:
Apparently things DO work, if one does them properly XD
Unless this is a serendipitous “positive error” that I am somehow making :wink:

The plugin is actually updated at the moment to support version 0.19. If you press cmd + , to open up the options and then search for “elm” you will see two relevant options. “Elm: Compiler” is for 0.19+ and needs to be set to something like ./node_modules/.bin/elm, while “Elm: Make Command” is for 0.18 and earlier and needs something like ./node_modules/.bin/elm-make. This will work for local Elm installations, though if you use a global installation you may need to run which elm/which elm-make to find the path you are using.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.